FIX - RadioMaster Zorro won't show up as a know USB device

If you’ve recently purchased a RadioMaster Zorro and you want to use it with a sim but you’re having trouble connecting it as a USB device with your PC/laptop (as I did), there may be a rather simple fix.

There’s a chance you might be using the USB port on the bottom of the controller to try and connect - if so, this will not work as it is a charging-only port. To connect the Radiomaster Zorro as a USB device and enable it to work with a sim, you will need to use the port on top of the controller which is hidden underneath the cover. Once you connect using this port, select “USB Joystick” on the on-screen display, and the controller should be recognised and be ready to use with a SIM.

Also found that USB cables used with an adaptor to get a USB C connector at both ends are direction sensitive. The adaptor should be at the computer end, the USB C end of the data cable should go in the Zorro port on the side facing away from the user (see post above).

1 Like